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 Important Information
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1
What Is Lookout?

Lookout is a highly productive automation software package with an 
easy-to-use interface. Lookout is used to control, monitor, modify, analyze, 
or report on your industrial automation applications.

You do not need to use programming or script writing to create Lookout 
processes. This makes Lookout the quickest solution to get your 
automation processes up and running.

Why Choose Lookout?
National Instruments Lookout is the easiest to use HMI SCADA software 
on the market. This, combined with the easy-to-use networking and 
drag-and-drop development environment, makes Lookout a highly 
productive tool to create your industrial automation applications.

Lookout is used to control many types of industrial applications, from 
manufacturing a variety of products to providing essential services. 
Lookout is being used to brew beer, process food, run chemical and 
petrochemical plants, operate oil and gas pipelines, automate buildings, 
control energy management systems, bottle soft drinks, operate power 
plants, and operate municipal water supplies.

The total cost of ownership of software includes development, 
maintenance, and training costs. With Lookout, you cut down on these 
costs and get faster return on your investment—guaranteed. If, after using 
a purchased copy of Lookout for 90 days, you do not find it to be the 
easiest-to-use software on the market, we will refund your money.

How Does Lookout Work?
With Lookout, you can create a control process in three basic steps. First, 
you select the type of object you want to create from Lookout’s large 
library of control, driver, and display objects. Second, you configure the 
object using Lookout’s enhanced productivity tools, which include the 
Lookout Object Explorer; Connection Browser; and special expression, 
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connection, and data point configuration dialog boxes. Finally, you make 
connections between your objects using a simple connection dialog box. 

Since the Lookout interface includes the controls you need to connect 
objects and drivers, Lookout lets you avoid time-consuming programming 
and scripting.

Object-Oriented
When you develop a control process in Lookout, you create specific objects 
such as controls, trend charts, and hardware drivers. Lookout’s library of 
object classes includes a vast selection of objects.

Lookout comes with advanced objects, such as the Loader, the Monitor, and 
the Symbolic Link, that you can easily use to create emergency backup 
systems to take over in case of system failures. You can also use objects to 
create and run a multitude of processes from a single process template—all 
done the easy Lookout way.

Each programmable logic controller (PLC), remote terminal unit (RTU), or 
protocol driver object you create comes already equipped to read from and 
write to the field hardware connected to your computer.

Connections
In Lookout, you create connections between objects to meet a variety of 
control process needs. You can create one-way connections, reciprocal 
connections (as shown in the Create a Client Process example in 
Chapter 3, Try Out Lookout), and complex connections that test logical 
conditions or perform calculations on a value.

Expressions
Edit Lookout expressions (the objects on your control panel) so that they 
process and analyze data while it is being reported. Expressions can also 
test current conditions to make fast and efficient adjustments to processes.

Event Driven
Events drive Lookout. This means that Lookout is notified immediately 
when a change occurs in a setpoint, I/O value, or expression (instead of 
waiting for continuous software operation loops to make their way around 
to checking a value).
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Online Configuration
With Lookout online configuration, you change system configurations 
without quitting your control processes. You can even develop and modify 
a Lookout process while your application is running. Lookout remains 
completely online while objects are being added to the application. This 
means that there are no gaps in your data, alarm, and event records when 
you do maintenance or upgrade your processes. 

Multi-Server and Multi-Client Networking
Connect any number of computers running Lookout server and client 
processes. The TCP/IP networking protocol integrated into Lookout makes 
networking as easy as dragging a data point to a control panel display, or 
typing in a Uniform Resource Locator (URL).

Web Capabilities
With the web client feature of Lookout, you can monitor and control a 
Lookout process from any computer connected to the Internet. In seconds, 
you can create a basic HTML page, following the simple export procedure 
in Lookout. You can then access your client process through Microsoft’s 
Internet Explorer. The advantage of accessing Lookout client processes on 
the web is that you do not need Lookout software on the computer being 
used as a web client. (To experience how easy it is to create a web client, 
see the Create a Web Client exercise in Chapter 3, Try Out Lookout.)

Graphics
Lookout includes an extensive library of graphics you can use to customize 
your process control panels. Graphics can be either static (like text labels) 
or animated (graphically representing changes as they occur in your 
processes). The water tank in the Create a Server Process example in 
Chapter 3, Try Out Lookout, includes both static and a simple animated 
graphic displays.

Lookout supports metafiles (.wmf) and bitmap graphic files (.bmp). You 
can also import AutoCad files and photographs as bitmaps or metafiles.

Distributed Alarms and Events
Use any computer running Lookout to monitor alarms and events generated 
by any Lookout process. Lookout lets you set up to ten alarm priorities. 
You use these priorities to group and filter alarms and events, which lets 
you focus on what is most important in a given circumstance. You 
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acknowledge alarms from any computer in a network using a single 
keystroke. In addition, Lookout includes the following alarm reporting 
features:

• Voice annunciation using .wav files

• Alarm/event reporting that you can define for each object

• Filtered alarm/event report printing

• Distributed alarm/event logging

Security
Lookout security works both on individual controls and across networks. 
Lookout lets you set up to ten security levels. You can use the security 
features to limit panel retrieval and viewing, individual object control, and 
determine if Lookout can be closed or minimized. 

With Lookout, you can automatically start up a process when you power up 
your computer.

Distributed Data Logging
Lookout logs alarms, events, and data to its internal Citadel database. 
The Citadel historical database is the highest-performing real-time 
historical solution currently available in the market. Citadel includes an 
open database connectivity (ODBC) driver that enables other databases 
(such as Access and MES) to retrieve historical data using structured query 
language (SQL). You can log data from any computer running Lookout on 
your network to any other Lookout computer, and then access that data 
using SQL queries. You can also log data to spreadsheet files, or to other 
applications using dynamic data exchange (DDE). You can log data at 
regular intervals, on demand, on occurrence of an event, or in any 
combination of these logging schedules. You can log data to any computer 
on your network, and retrieve data from any computer, just as easily as you 
accomplish the networking tasks in the Networking exercise in Chapter 3, 
Try Out Lookout.

Trending
You can display data from a number of different sources at one time using 
the Lookout HyperTrend object. You can also create groups, each one 
having its own data set to display and its own scaling and time constraints. 
You can define as many HyperTrend objects as you want. Each object can 
plot as many numeric (analog) and /or logical values as you want. 
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Report Generation
Lookout lets you create custom reports using your favorite spreadsheet 
package. You can also configure Lookout to create automatic scheduling 
and on-demand reports.

Telemetry
Lookout allows multiple protocols to share the same serial port and, 
therefore, the same radio frequency. For instance, you can have different 
manufacturers’ PLCs and RTUs using different communications protocols 
on the same line using one modem.

Hardware Connectivity
Lookout is a fully-compliant OLE for Process Control (OPC) client and 
server, allowing full connectivity through the industry standard for open 
multivendor connectivity. 

Lookout offers seamless integration with National Instruments hardware, 
such as FieldPoint and Data Acquisition (DAQ) products. Lookout also has 
dozens of custom drivers to help you control PLCs and RTUs from a wide 
variety of manufacturers. 

Combined with National Instruments LabVIEW or BridgeVIEW software, 
you also bring motion control and machine vision to your control 
processes, and access a full spectrum of analysis and measurement options.
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2
Getting Started

This chapter describes the system requirements for the Lookout software 
and contains installation instructions.

System Requirements
Make sure you have the following minimum components in place before 
you attempt to install and use Lookout:

• Pentium class PC running at 90 MHz or faster

• 32 MB RAM

• Windows NT version 4 or later, or Windows 98/95

• 45 MB free disk space

• Another 20 MB or more free disk space (depending on how much data 
you intend to log to the internal Citadel database)

• If you want to experiment with Lookout’s networking capabilities, 
your computer must have TCP/IP installed and functioning. See the 
Testing TCP/IP topic of the Lookout online help for more information 
on this requirement.

• If you want to explore Lookout’s networking capabilities (as shown in 
the Networking exercise in Chapter 3, Try Out Lookout), you need 
access to a second computer on your network that meets all of the 
above requirements.

• If you want to create a web client, your computer must have Microsoft 
Internet Explorer, version 3.2 or later.

Lookout is Y2K compliant and requires no special considerations for the 
year 2000.
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Install Lookout
Follow these instructions to install the Lookout software:

1. Before you install Lookout, make sure you have shut down all 
applications.

2. Insert the Lookout CD into your CD drive.

3. Follow the prompts on the screen to complete the Lookout installation. 

The Lookout CD has autorun capability. If for some reason the autorun fails 
to start the CD installation routine, follow these instructions:

1. Click on the Start icon in the taskbar and select Run.

2. Enter N:\SETUP, where N represents your CD drive. Then, select OK.

• Use Browse to enter the name of an alternate directory, or select 
Next to accept the recommended directory name.

• Lookout lets you choose whether to install its online help. 
However, if you choose not to install the online help, the Lookout 
help buttons will not work.

• Make sure you select the option to install Lookout’s ODBC driver 
if you want to be able to access Lookout’s internal Citadel 
database.

• On a Windows NT system, if you want to be able to block 
authorized users from using <Alt-Tab> to gain access to 
applications other than Lookout, make sure you install the 
optional NT keyboard driver from the list of optional components.
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3
Try Out Lookout

This evaluation guide contains the following exercises that lead you 
through the following Lookout activities:

• Create a Server Process—Build a process that runs on your computer. 
This exercise shows how easy it is to connect Lookout to hardware, 
control the hardware, and display values from the hardware registers. 
You will use this process as the server process in the rest of the Lookout 
evaluation exercises.

• Create a Client Process—Create a client process to access and control 
your server process.

• Create a Web Client (optional)—Experiment with the web client 
capabilities of Lookout.

• Networking (optional)—Learn how to run a client process on any other 
computer on your network.

Your evaluation copy of Lookout allows you to have up to ten I/O points 
and two client connections. You can run evaluation copies of Lookout on as 
many computers on your network as you like. Your evaluation copy will run 
for one hour at a time. Before Lookout shuts down, you will be given the 
opportunity to save your process. The Lookout evaluation software has no 
expiration date.

Tip The Lookout online help contains information on all the Lookout objects, features, 
and services, as well as a developer tour that includes a brief tutorial.

Create a Server Process
A Lookout server process is an application that directly controls and 
monitors field hardware. You run Lookout server processes on computers 
that have direct, physical connections to industrial automation hardware. In 
this exercise, you simulate connections to hardware.

Note While server is a networking term, a Lookout server process does not necessarily 
need to be connected to a network. You would create a Lookout server process for any 
non-networked task you want to use Lookout to perform.
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In this exercise, you create and configure Lookout objects, make and edit 
connections between those objects, and configure data for logging.

1. Start Lookout by selecting Start»Programs»National Instruments 
Lookout»Lookout 4.0.

2. Close the Demonstration process (if necessary) by selecting 
File»Close All.

3. Select File»New to create a new Lookout process. 

4. In the Create Process dialog box, name your process Eval_Server, 
as shown below. Leave the rest of the fields with their default settings.

 

Tip Click on the Help button for more information about any of the areas on a dialog box. 

5. Click on OK.

6. In the New Control Panel dialog box that appears, change the Title to 
Lookout Evaluation Server Control Panel.

7. Click on OK.
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Tip Notice that the status bar at the bottom of the Lookout workspace turned yellow when 
you created your new process. This signals that Lookout is in Edit mode. If you find you 
cannot create an object or you have trouble with completing some of the steps in the 
evaluation exercise, check to see whether Lookout is in Edit or Run mode. You can change 
modes by pressing <Ctrl-Space>.

8. Select Object»Object Explorer. 

You use the Lookout Object Explorer to examine Lookout processes 
running on any Lookout computer on your network, create new 
objects, arrange objects in hierarchical folders, make connections, 
edit data members, and register computers running Lookout on 
your network. 

For more information on the Lookout Object Explorer, select 
Help»Contents from the Lookout menu, then view the Object 
Explorer topic.

9. Arrange your Lookout workspace so that you can see both your control 
panel and the Object Explorer. The following illustration shows how 
your Lookout screen might look when you complete the following 
exercises. Various Lookout features you will be learning about are 
labeled to help you orient yourself in the Lookout workspace.
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♦ Lookout handles discrete, batch, and continuous processes.

♦ Lookout can handle an unlimited number of objects, I/O points, and 
graphic panels.

1 Active process name
2 Title bar
3 Control panel

4 Active alarm/event count
5 Control panel navigation 

arrows

6 Status bar
7 Alarm window
8 Minimized control panel

9 Object Explorer
10 Root window
11 Lookout menu

6

2 31

5 44

7

8

9

10

11
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Create a Server ModbusSlave Object
1. Right-click on the Eval_Server process in the Object Explorer, and 

select New Object from the menu. The Select Object Class dialog 
box appears.

2. Define your object. Open the Drivers folder and select the 
ModbusSlave object. Notice that a description of this object appears 
in the field to the right of the list of objects.

3. Click on OK. The New Modbus Slave dialog box appears, as shown 
in the following illustration. For this example, accept the default values 
for the object ModbusSlave1 by clicking on OK.

 

4. The Modbus Slave object, ModbusSlave1, appears under your 
Eval_Server process in the Object Explorer.

Note These exercises use the ModbusSlave driver object because it does not return errors 
if it cannot locate hardware connected to your serial port. You use the ModbusSlave driver 
object as you would any PLC or RTU driver object.

♦ Connecting to hardware is done similar to creating the Modbus Slave 
object.
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Create and Connect a Server Pot Object to Your Modbus Slave
1. Expand the tree view of your newly created ModbusSlave1 object by 

clicking on the + sign to the left of it in the Object Explorer, as shown 
in the following illustration. This lets you view the data members 
available for you to use.

2. Right-click and drag the 40001-49999 data member range to your 
control panel. Release the mouse button and select Create 
Control»Pot.

  

Tip Pot is an abbreviation for potentiometer. In Lookout, you use Pot objects to set or 
control analog outputs.
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3. The New Potentiometer dialog box appears, as shown in the 
following illustration.

 

4. Accept the default values for the object Pot1. Click on OK. 
The following dialog box appears.

5. Select the vertical slider (top row, second graphic).

6. Select the Use as Default checkbox, then click on OK. You can 
position your object wherever you like on the control panel. 



Chapter 3 Try Out Lookout

Lookout Evaluation Guide 3-8 www.ni.com

7. Use the sizing handles to change the size of your Pot (slider) object.
 

♦ Lookout features easy-to-use drag-and-drop project development.

8. To check that your connection works, place a display for the 
ModbusSlave1.40001 data member on your control panel by 
clicking on 40001—49999 in the Object Explorer and dragging 
it to your control panel. This inserts a digital representation of the 
40001 register on the control panel.

9. Use the sizing handles around the number to make the display large 
enough to show three digits.

10. View your process in action. Press <Ctrl-Space> to leave Edit mode, 
then use your pointer to move the Pot slider up and down. Notice the 
number displayed in the expression changes as you move your Pot 
control. Your Pot (slider) object output is connected to the 
ModbusSlave1 data member 40001, and the value the Pot sets for 
that data member is displayed as a number on your control panel. 

♦ In ten simple steps, you have created and configured a driver object to talk 
to field hardware, connected a control to that driver object, displayed the 
register you are connected to, and tested the process.
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The connection between your Pot control and your ModbusSlave driver is 
a remote source connection. This connection responds to changes in the 
control from sources other than itself, making your control an indicator as 
well as a control. If you want your control to hold the value you set even if 
something changes the value in your PLC or other device, you can use a 
local source direct connection. With this type connection, Lookout will 
restore the control to the device when possible. For more information on 
creating and using local source direct connections, see the Lookout 
documentation.

♦ With Lookout online configuration, you can change system configurations 
without shutting down your control processes. You can even develop and 
modify a Lookout process while your application is running. Lookout 
remains completely online while objects are being added to the 
application. This means that there are no gaps in your data or alarm and 
event records due to maintenance or upgrading of your processes. 

The display you created to show the value of the ModbusSlave1.40001 
register is a Lookout expression (a flexible way to display, process, and use 
data in Lookout). Take a few moments to explore this expression.

1. Select File»Save to save your server process.

2. Press <Ctrl-Space> to return to Edit mode (the status bar at the bottom 
of the Lookout workspace should turn yellow). 

3. Re-examine your expression. Right-click on the digital display and 
select Object Properties. The Revise expression dialog box appears. 
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4. With this dialog box, you can do such things as perform calculations 
or logical tests on data, and change the path relativity. When you are 
finished looking at this expression, click on OK.

Tip For more information about Lookout expressions and how to put them to use, click on 
the Help button in the Revise Expression dialog box.

Customize Your Display
1. Modify your Modbus Slave display properties. Right-click on the 

digital display expression. This time, select Display Properties. The 
following dialog box appears.
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2. Select the Bar (up) option in the Display Style section of the dialog 
box, and set the Bar Color to blue. Set the Background Style to Plate. 
Click on OK. 

3. In the control panel, adjust the size of the bar using the sizing handles.
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4. Press <Ctrl-Space> to leave Edit mode, then move your Pot slider up 
and down. The Modbus Slave value is now displayed as a blue bar 
instead of as a number.

5. Press <Ctrl-Space> to return to Edit mode.

6. Add a graphic to your display. Select Insert»Graphic. The following 
dialog box appears.

  

7. Open the Tanks folder, and select the first water tower graphic in the 
fourth row, Tank1_A.WMF. Click on OK.

This particular graphic has a transparent center (indicated by diagonal 
hatch marks). You can position it over your bar display to give a 
graphic representation of a tank’s fullness.

8. Position the water tower over the bar indicator, and re-size it as shown 
in the following illustration. This creates a simple, animated display 
that shows you how full the water tower is at any given time.
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Tip You can create more complicated animations using the Lookout Animator object; see 
the Graphics and the Animator topics in the Lookout online help for more information.

9. Add a scale to the Pot slider. Right-click in the control panel and select 
Insert Scale. The following dialog box appears.
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10. Accept the default settings and click on OK. Position this scale next to 
the slider.

11. Select Insert»Text/Plate/Inset from the Lookout menu, and place a 
label that says Percentage Full below the scale on your control 
panel.

 

♦ Lookout includes an extensive library of graphics you can use to customize 
your process control panels. Lookout supports Windows metafiles (.wmf) 
and bitmap graphic files (.bmp), In addition, you can import AutoCAD files 
or photographs.

Configure Data for Logging
You now have a control you can use to set the water level in your simulated 
tank and a scale that shows what percentage of the tank should be full. You 
might also want to know how many gallons of liquid the tank is holding, 
display information about the tank and its contents graphically, and trigger 
alarms when the tank is too full or almost empty.

To keep track of this data and to make it easier to handle, Lookout uses the 
internal Citadel database. Each time you create a Lookout object, every one 
of its data members is a potential entry in this database. You can log data to 
your local computer or to other computers running Lookout anywhere on 
your network. 
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Let us assume your tank holds 250,000 gallons. You can configure a 
database entry for your tank to track how full the tank is (in gallons), 
automatically convert the percentage measurement to a volume 
measurement, and handle your logging and alarming.

1. Right-click on the ModbusSlave1 object in the Object Explorer. 
Select Edit Database. 

2. Enter the values shown in the following dialog box.
 

a. Select the 40001 data member you connected your Pot object to 
by selecting 40001-4999 in the Native Members list. Assign it 
an Alias of TankLevel. 

b. In the Scaling section of the dialog box, set the Raw units at 0 for 
the Minimum and 100 for the Maximum. These are the raw 
numeric values connected to the 40001 data member, indicating 
what percentage of the tank is currently full. Set the Eng. units 
to 0 for the Minimum and 250000 for the Maximum. 

Lookout now automatically scales the 0–100 input to a value 
between 0–250,000 that you can display using the alias value 
TankLevel.

c. Check Log to historical database, and set the Lifespan to 5 days.
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d. Set the Deviation to 1.5. (This part of the database editing will be 
used in the next exercise.)

e. Set your Alarm conditions as shown. Notice that Lookout lets 
you divide alarms into groups, called alarm areas. (In this case, 
you create an alarm area called Tanks by typing Tanks into the 
Area field.)

Tip For more detailed information on editing the Citadel database, click on the Help 
button in any Edit Database dialog box. Refer to the Alarms and Events topic in the 
Lookout help for more information on alarms and alarming.

f. Click on the Save button (or the Update button if you saved earlier 
in the process), then click on the Quit button to exit the database 
editing dialog box.

3. Expand the ModbusSlave1 object in the Object Explorer by clicking 
on the +, and drag the scaled data member TankLevel to your control 
panel. This digital display reports the contents of your tank in gallons.

Your control panel should now look something like the following 
illustration.
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Tip To create the label with the number of gallons, select Insert»Text/plate/Inset to 
insert a label with the word “gallons,” then select Justify right. Select your digital display 
on the control panel, and in the Display properties, set the background style to 
Transparent. Then, drag your digital display over your text label, and select Move to 
Front from the Arrange menu.

4. Press <Ctrl-Space> to exit Edit mode, then move the Pot slider up and 
down. Moving the Pot to the upper and lower limits of its range triggers 
the alarms you set for the database member TankLevel. 

5. Right-click on an alarm in the Alarms window and select 
Acknowledge All to acknowledge the alarms. You do not need to enter 
a comment.

Tip If you want to change the size and location of the Alarms window, select 
Alarms»Display Options. To control what is displayed in the Alarm window, select 
Alarms»Filter Options. For a more detailed description of alarms and alarming, refer to 
the Alarms and Events topic in the online help.

6. Save your server process. You will be accessing it with the client 
process you create in the next example.

Tip You can add network and local security to this server process. To learn more about 
using the Lookout security features, view the Security topic in the Lookout online help.

♦ Log data to any computer on your network, and retrieve data from any 
computer.

♦ Set alarm points, login values, and convert scaling in one easy dialog box.

♦ View and acknowledge alarms from any computer on the network.

Review—Creating a Server Process
A Lookout server process is an application that is connected to hardware 
and provides data for clients. Run Lookout server processes on your 
computers that have direct, physical connections to your industrial 
automation hardware. You use Lookout driver and protocol objects to build 
Lookout servers. You may not need or want to use Lookout in a networked 
environment. Any Lookout process you build to run on a computer 
connected to field hardware can be built the way this server example is, 
even if you are not planning to use Lookout’s networking features. If you 
are not networking Lookout, you may find that it is useful to develop more 
than one process to run on a single Lookout computer—the basic server, 
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and one or more client processes with different security properties for 
different operators using the standalone system.

Create a Client Process
In this exercise, you build a simple Lookout client process to interact with 
the server you built in the Create a Server Process exercise. 

A Lookout client process can run on the same computer as a server, or on a 
different computer. You can create a set of clients to run on the same 
computer as your server process, each addressing different parts of the main 
process, or perhaps with different security setups. The central idea behind 
a Lookout client is to create a process that works through a server process, 
not directly with field hardware. In this way, the client process becomes 
completely portable and flexible. 

The instructions for this exercise assume you are developing your client 
process on the same computer that is running your server process. You 
could just as easily develop a client on a different computer running on your 
network, and in the Networking exercise, you will have a chance to move 
the client to a second computer, add a feature, and fix a data quality 
problem that is intentionally inserted when you build the client to 
demonstrate how easy trouble-shooting is in Lookout.

1. Launch Lookout if it is not already running.

2. Load your Eval_Server process using the File»Open command.

If you did not save your server process from the previous example, you 
can use the Eval_Server sample process, found in the Examples 
folder installed with your evaluation copy of Lookout.

3. Minimize your server process control panel by clicking on the 
minimization box ( ) in the upper-right corner of the control panel.

4. Select File»New to start a new Lookout process. 

5. In the Create Process dialog box that appears, name your new process 
Eval_Client. Click on OK. 

6. In the New Control Panel dialog box appears, change the Title to 
Evaluation Client Control Panel, and click on OK.
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Create a Client Pot Object
1. From the evaluation server process, right-click and drag the 

40001-49999 data member range to your control panel. Release the 
mouse button and select Create Control»Pot. 

The remote connection is defined by a URL, which directs Lookout to 
the target value. Properly configured, a remote position source 
connection works on any computer running Lookout on your network.

2. Right-click in the green URL field in the New Potentiometer dialog 
box. The following dialog box appears.

  

The path \\.\Eval_Server\ModbusSlave1.40001 should work 
as long as you client is running on the same computer you used to 
create your client process—but your goal is to create a process that 
runs from any computer on your network that has Lookout installed. 
For this to be true, you must change the path.
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3. In a simple case like this one, you could just alter the URL by typing 
your computer name in the appropriate spot in the string. However, in 
order to show how the Lookout URL editor works, delete the old URL 
string. You can then assemble a new URL by making the following 
selections in the dialog box:

a. Set Path Mode to Absolute. This ensures that your client can 
find its way to the data member you are connecting to, no matter 
what computer the client is run on.

b. Open the Eval_Server process in the left tree view, and select 
ModbusSlave1. 

c. Select the 40001 data member in the Contents list.

d. The assembled URL string is displayed next to the Paste button. 
Click on Paste to insert the URL string into the green URL field. 

e. Click on OK.

Note Notice that the illustration features the name for the computer used to take the 
illustration screen shot. Your own computer name should appear instead of 
paroikos.dy.natinst.com. 

Tip Remember that you always create a connection from the controller to the object or 
server you want to modify.

Tip For more detailed information on creating and editing URLs, click on the Help button 
in any URL Editor dialog box. For more information on Lookout paths and path relativity, 
refer to the Path Names in Lookout help topic.

4. Click on OK in the New potentiometer dialog box to create the new 
Pot vertical slider object.

5. Use the sizing handles to modify the size of your Pot object.

6. Press <Ctrl-Space> to leave Edit mode. Activate your server process 
control panel by selecting Window»Lookout Evaluation Server 
Control Panel.

7. Arrange your two control panels so you can see both. Operate the Pot 
control in the client process control panel. Notice that both the Pot 
control and the ModbusSlave data member (on the server process) 
operate in unison with the Pot control in your client process.

8. Operate the Pot control in your server process. Notice that the Pot 
control in your client process changes to reflect movement of the 
server values.
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Your client process affects the server process in this way no matter 
what computer on the network it is run on.

Connect a Client Switch Object to Your Modbus Slave
1. Press <Ctrl-Space> to return to edit mode (the status bar at the bottom 

of the Lookout workspace should turn yellow).

2. Right-click on your Eval_Client process in the Object Explorer, and 
select New Object.

3. From the Control folder, select Switch and click on OK. The 
following dialog box appears.
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4. Select the Remote option, and right-click in the green URL field. The 
URL Editor dialog box appears.

 

When you created your Pot object for your client, you used the Path 
Mode to make sure the URL path would work from any computer on 
your network. Another way you can ensure portability for this control 
is to change the root of the Signals list box.
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5. Click on the down arrow in the root box below the Paste button, as 
shown in the following illustration.
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6. Select Universe. Expand the Network node in the tree that appears, 
pick your computer under the Network node, then expand the 
Eval_Server process. Select the ModbusSlave1 object as shown in 
the following illustration. 

 

7. Select the 1-9999 data member in the Contents list and click on Paste 
to insert the URL string into the green URL field. 

8. Click on OK.

9. Click on OK in the New Switch dialog box to finish creating your 
Switch object.

10. Drag the Switch object from the Object Explorer to your client control 
panel. This panel should now contain a Pot object and a Switch object.
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11. In the Object Explorer, expand the ModbusSlave1 object in your server 
process as shown in the following illustration, and drag and drop the 
ModbusSlave1.1 data member from your Eval_Server process to 
both your client and server control panels.

 

12. Press <Ctrl-Space> to leave Edit mode, and operate the switch you 
placed on your client control panel. Notice that the client panel display 
of the Modbus Slave data point operates just the same as the display in 
the process actually containing the object.

♦ Connecting to an I/O point across a network is as easy as connecting it 
from the same computer.
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Create a HyperTrend Object
When you configured the TankLevel data member in your server process 
for scaling (see the section Configure Data for Logging), you also set it to 
be logged to Lookout’s Citadel database. As long as your server process is 
running, Lookout is keeping track of this value in the Citadel database.

1. Make note of the current time on your computer, then change the 
position of the Pot slider on your client or server process a number of 
times in large increments/decrements. Later, you will view the changes 
you made on the HyperTrend chart.

2. Press <Ctrl-Space> to return to edit mode.

3. Right-click on your Eval_Client process in the Object Explorer and 
choose New Object. Select HyperTrend from the Logging folder. 
The following dialog box appears.



Chapter 3 Try Out Lookout

© National Instruments Corporation 3-27 Lookout Evaluation Guide

4. Click on the Add Group button. The following dialog box appears.
 

5. Name the group TankLevels. The default trend width is one minute; 
you can leave it in place and accept the other defaults. 

6. Click on OK. Lookout returns you to the primary Create 
HyperTrend dialog box. Make sure your new TankLevels group is 
highlighted, and then click on the Add Item button. The following 
dialog box appears.

7. Set Maximum to 250000 to match the scaled value of the data point 
you are about to display.
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8. Right-click in the green URL field to activate the URL Editor. The 
following dialog box appears.

 

9. Set Path Mode to Absolute, then select the ModbusSlave1 object 
in your Eval_Server process in the left tree view. Select the 
TankLevel data member in the Contents list. Click on the Paste 
button, then click on OK.

10. Click on OK in the Add Item dialog box and again in the Create 
HyperTrend dialog box. 
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11. Drag your new HyperTrend object from the Object Explorer to your 
client process control panel. Use the sizing handles to adjust the size 
of the chart. Your client process control panel should now resemble the 
following illustration.

View Your HyperTrend Data
1. Press <Ctrl-Shift> to toggle out of Edit mode. Move the Pot slider up 

and down and notice the trace change on the graph.

2. Click on the HyperCursor icon in the center of the top of the 
HyperTrend object. The HyperCursor icon is replaced by a solid line 
down the center of the chart, and the HyperTrend1 Cursor dialog box 
appears, as shown in the following illustration.

1 Modbus Slave 1.1 Digital Output Switch 2 Modbus Slave 1.1 Digital Output Indicator 3 Hypercursor icon

2

3

1
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3. You can use either the Time controls on the dialog box or left-pointing 
arrowheads at the top of the HyperTrend chart to scroll back to the time 
you noted when you changed TankLevel values (the larger the 
arrowhead, the faster the scroll speed). 

4. Select File»Save All from the Lookout menu to save both your 
processes.

♦ You can define as many HyperTrend objects as you want. Each object can 
plot as many numeric (analog) and /or logical values as you want.

Review—Creating a Client Process
Lookout client processes are intended to interact with Lookout servers. 
A properly-made Lookout client process should be capable of running on 
any computer running Lookout on your network without modification.

To ensure this portability, there are a few simple development rules to 
follow when creating a Lookout client process, which are explained in 
detail in the Lookout online help. The essence of these rules is that a 
Lookout client application should not connect directly to field hardware, or 
refer directly to or depend on the computer on which the client process is 
running. 

To meet these conditions, you should not use a driver object in a Lookout 
client, and you should always use remote connections from a client process 
to a server process (rather than making a direct connection). 
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Still, because mistakes are not uncommon in the real world, a small error 
has purposefully been made in the client you just built to allow you to 
debug the process in the Networking exercise.

Create a Web Client
You can create a version of any Lookout process to access using Microsoft 
Internet Explorer, 3.2 or later. With a Lookout client, you not only can 
access, but also control your process from anywhere in the world. In this 
exercise, you will find out how easy it is to do this.

1. Open Lookout and run your Eval_Client and Eval_Server 
processes.

2. Press <Ctrl-Space> to put Lookout in Edit mode.

3. Select File»Web Server Export Options. The following dialog box 
appears.

4. In the Export directory field, enter the complete path to the directory 
in which you want to create your Lookout web client HTML page. All 
the necessary support files are also placed in this directory. (If no 
directory exists on the path you enter, Lookout will create one.)
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5. Server URL is the URL for your HTML page.

• If your computer is running web server software, enter the 
complete web server path to the page, but do not include the page 
itself. For example, if the complete URL to your page is 
http://webserver/directory/client.html

enter
http://webserver/directory/

• If your computer is not set up as a web server, you can still create 
a web client to use with your web browser, but you can only open 
it in your own computer. It will not be visible to a browser running 
elsewhere on your network. Enter the same path you entered in the 
Export Directory field, such as 
c:\directory

6. Click on OK.

7. Select File»Export Web Server Files. The following dialog box 
appears.

 

8. Select your Eval_Client process for export. Click on OK. 
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You now have an HTML page your can access with a browser. To access 
the page, complete these steps: 

1. Make sure Lookout is running your server process so the web client 
has a server to access.

2. Open Internet Explorer.

3. Set the security level option in Internet Explorer to Low.

4. Use Internet Explorer to open the web client file.

5. Operate the client process through the web. Notice that your web client 
controls the server process just as the Lookout client did.

♦ If you are using the web client, you do not need Lookout software on the 
computer. Lookout downloads the necessary files.

Networking
If you have access to a second computer on your network, you can run your 
new client on that computer and try out Lookout’s easy-to-use networking. 
This exercise shows how a client process developed in a server computer 
can be distributed across any machine in a network. The client process 
works with absolutely no development.

1. Install your Lookout evaluation software on the second computer. 

2. Copy your client process files from your first computer to the Lookout 
directory on your second computer. If you did not change the name of 
your process when saving, you should have the following four files that 
comprise your client process:

• Eval_Client.l4p

• Eval_Client.l4t

• Eval_Client.lks

• Eval_Client.lka

Note For more information about Lookout file types, refer to the online help.
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3. On your second computer, launch Lookout, select File»Open, and 
open Eval_Client.l4p. The Lookout default is to open a process 
with the control panels minimized, as shown in the following 
illustration. 

 

4. Activate the control panel by clicking on the activate ( ) button on the 
minimized menu bar at the bottom of the Lookout workspace.

You can operate the Pot object slider on your second computer. The Pot 
controls in your server and original client processes (running on your 
original computer) should respond.

Register Your Network Computers
While Lookout processes can communicate with each other across the 
network without any special preparations, you must register all other 
computers running Lookout if you want to browse across the network for 
development purposes.

1. Press <Ctrl-Space> to put Lookout in Edit mode. Select Object» 
Object Explorer if the Object Explorer is not already running. 
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2. Click on the name of your second computer in the window at the top 
of the Object Explorer, and select Universe from the pull down list, as 
shown in the following illustration. 

 

You can now browse every computer registered as running Lookout on 
your network. 

3. Register your original computer (the one running your server process) 
by right-clicking on Network and selecting Register computer.
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4. In the Register Network Computer dialog box that appears, type the 
name of your original computer into the Computer name field, as 
shown. If you prefer, you can browse for your computer name in the 
network tree view available in the Entire Network field.

 

5. Click on OK. 

6. Expand the Network node of the tree view in the Object Explorer. You 
should see both your second computer (the computer you are currently 
working on) and your original computer (the computer running your 
server process).
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Correct Problems with Data Quality 
You may notice that the digital display indicator on your second computer 
has a red X superimposed on it. This is an example of the Lookout data 
quality feature, alerting you that your process is receiving data that has 
some problem. Complete these steps to fix any data quality problems.

1. Delete the display with the data quality alert (red X) over it from your 
client control panel. Select the display, and press <Delete> on your 
keyboard.

2. Expand the Object Explorer tree view so that you can see the processes 
running on your original computer as well as the ModbusSlave1 
object in the Eval_Server process, as shown in the following 
illustration.

 

3. Replace the display you deleted in the previous step. Drag the 1-9999 
data member to your client control panel. Notice that the new display 
object no longer shows the data quality alert (red X).

4. Press <Ctrl-Shift> to exit Edit mode and operate your switch. If you 
can see your original computer, you should notice that the display 
works in unison with the displays on the client and server processes 
running on your server computer.

5. Select File»Save to save your changes.

♦ With Lookout, networking is as easy as using Windows Explorer.
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Synchronize Computer Clocks
You might notice some time lag in operating your Pot control and seeing 
the change in your HyperTrend chart on your original computer. This can 
happen when your networked computers do not have their clocks 
synchronized to show the same time. To provide for accurate data logging, 
follow these steps to have Lookout synchronize your computers.

1. Select Options»Time Synchronization from the Lookout menu bar. 
The following dialog box appears. 

 

2. Click on Add. The following dialog box appears.
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3. Enter the name of your original computer in the Computer name field 
of the Add Time Server dialog box. You can also browse for your 
computer in the Entire Network list.

4. Click on OK. The Time Synchronization Settings dialog 
box reappears.

 

5. Set Sleep time to 300. With this setting, your computers resynchronize 
every five minutes.

6. Click on OK. Your computers are now synchronized.

7. Select File»Save to save your changes.
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Show Networked Alarms and Events
If you operate your Pot slider to the top and bottom, you may notice that the 
alarms you trigger on your original computer do not appear in the Alarms 
window on your second computer. To monitor and acknowledge alarms 
from a network computer, you must select the processes you want to 
monitor.

1. Set your second computer to monitor alarms on your original 
computer. On your second computer, select Alarms»Select Processes 
from the Lookout menu. The following dialog box appears.

 

2. Expand the tree view to show the processes running on your original 
computer. Select the Eval_Server process, and click on the Add 
button. Click on OK.

You second computer can now monitor alarms from your original 
computer.

3. Select File»Save to save your changes.

♦ Connecting to alarms across a network is done in one easy step.
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View and Acknowledge Alarms
1. Operate your Pot slider, leaving it in one extreme or another so that you 

have one active alarm (in red) along with no longer active alarms (in 
blue) in the Alarms window. 

2. To acknowledge alarms, right-click on an alarm in the Alarms 
window. Select Acknowledge All, as shown in the following 
illustration.

 

3. The Acknowledge dialog box appears. You can enter comments in this 
dialog box concerning the alarm acknowledgement.

 

4. Enter Alarm acknowledgement demonstration as the comment. 
Click on OK. 

The alarms in blue are cleared from the alarm window, but the active alarm, 
formerly in red, turns black, except for the alarm area.
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5. Double-click on the active but acknowledged alarm. The Alarm 
Properties dialog box appears, as shown in the following illustration.

  

You can check for details on any unacknowledged or active alarms. 

6. Click on Done.
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4
Where to Go from Here

This chapter introduces you to the demonstration processes and additional 
features included with your Lookout software, and describes how to 
uninstall your Lookout evaluation software. It also includes information 
to help you contact National Instruments to learn more about Lookout and 
other National Instruments products.

Explore Lookout Demonstration Processes
Your Lookout evaluation software includes a directory of demonstration 
processes, located in the Examples folder. These processes demonstrate 
many useful Lookout features and functionality that are not covered in the 
evaluation exercises. 

When you first open your evaluation copy of Lookout, a home process you 
can use to run the other demonstration processes runs automatically. If you 
disabled the autoload selection for this process, you can run it yourself by 
opening the Examples folder in your Lookout directory and opening the 
home.l4p process.

To keep Lookout from opening this process every time you launch the 
program, select Options»Startup from the menu and remove the 
home.l4p process.

After you have operated a process for a while, enter Edit mode by pressing 
<Ctrl-Space>. Select Objects»Connection Browser and use the 
Connection Browser along with the Object Explorer to examine 
demonstration processes and see how they work. 

More on Lookout
There are many more features in Lookout than are addressed in this guide. 
Some of the other major capabilities of Lookout are the SPC, SQL, batch 
management, sequential process management, and redundancy. Other 
features such as complex expressions, data tables, animated graphics, 
advanced security across networks, and connectivity with other National 
Instruments software makes Lookout very powerful. These, along with a 



Chapter 4 Where to Go from Here

Lookout Evaluation Guide 4-2 www.ni.com

host of other capabilities that are beyond the scope of this guide, make 
Lookout one of the most powerful software packages available on the 
market.

Uninstalling Your Lookout Evaluation Software
To uninstall your evaluation copy of Lookout, select Start»Programs» 
National Instruments Lookout»Uninstall Lookout Evaluation, and 
follow the onscreen directions. When the uninstallation process is 
complete, you might receive a message that some components could not 
be uninstalled. These files will be located in your Lookout directory, and 
include database files for data you logged during the demonstrations, and 
any process files you created. You can delete these files manually if you 
choose.

Where To Learn More About Lookout and 
National Instruments Industrial Automation Solutions

For more information about Lookout and other National Instruments 
industrial automation products, visit the National Instruments web site at 
http://www.ni.com/automation. You can also e-mail your questions 
to info@ni.com.

Your local National Instruments representative can supply information 
tailored to your needs. If you are not already in contact with a representative 
for your area, call National Instruments at 512 794 0100 to have your 
questions answered.

Thank you for your interest in Lookout.
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A
Technical Support Resources

This appendix describes the comprehensive resources available to you in 
the Technical Support section of the National Instruments Web site and 
provides technical support telephone numbers for you to use if you have 
trouble connecting to our Web site or if you do not have internet access.

NI Web Support
To provide you with immediate answers and solutions 24 hours a day, 
365 days a year, National Instruments maintains extensive online technical 
support resources. They are available to you at no cost, are updated daily, 
and can be found in the Technical Support section of our Web site at 
www.ni.com/support

Online Problem-Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of 

frequently asked questions (FAQs) and their corresponding answers or 
solutions, including special sections devoted to our newest products. 
The database is updated daily in response to new customer experiences 
and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through 
common problems and answer questions about our entire product line. 
Wizards include screen shots that illustrate the steps being described 
and provide detailed information ranging from simple getting started 
instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest 
editions of National Instruments hardware and software product 
manuals.

• Hardware Reference Database—A searchable database containing 
brief hardware descriptions, mechanical drawings, and helpful images 
of jumper settings and connector pinouts.

• Application Notes—A library with more than 100 short papers 
addressing specific topics such as creating and calling DLLs, 
developing your own instrument driver software, and porting 
applications between platforms and operating systems.
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Software-Related Resources
• Instrument Driver Network—A library with hundreds of instrument 

drivers for control of standalone instruments via GPIB, VXI, or serial 
interfaces. You also can submit a request for a particular instrument 
driver if it does not already appear in the library.

• Example Programs Database—A database with numerous, 
non-shipping example programs for National Instruments 
programming environments. You can use them to complement the 
example programs that are already included with National Instruments 
products.

• Software Library—A library with updates and patches to application 
software, links to the latest versions of driver software for National 
Instruments hardware products, and utility routines.

Worldwide Support
National Instruments has offices located around the globe. Many branch 
offices maintain a Web site to provide information on local services. You 
can access these Web sites from www.ni.com/worldwide

If you have trouble connecting to our Web site, please contact your local 
National Instruments office or the source from which you purchased your 
National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For 
telephone support outside the United States, contact your local branch 
office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, 
Brazil 011 284 5011, Canada (Calgary) 403 274 9391, 
Canada (Ontario) 905 785 0085, Canada (Québec) 514 694 8521, 
China 0755 3904939, Denmark 45 76 26 00, Finland 09 725 725 11, 
France 01 48 14 24 24, Germany 089 741 31 30, Greece 30 1 42 96 427, 
Hong Kong 2645 3186, India 91805275406, Israel 03 6120092, 
Italy 02 413091, Japan 03 5472 2970, Korea 02 596 7456, 
Mexico (D.F.) 5 280 7625, Mexico (Monterrey) 8 357 7695, 
Netherlands 0348 433466, New Zealand 09 914 0488, 
Norway 32 27 73 00, Poland 0 22 528 94 06, Portugal 351 1 726 9011, 
Singapore 2265886, Spain 91 640 0085, Sweden 08 587 895 00, 
Switzerland 056 200 51 51, Taiwan 02 2528 7227, 
United Kingdom 01635 523545
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